מחשב כף יד

צפייה בגרסה מלאה : מדריך | איך להוריד אפליקציות הדורשות גירסת iOS מתקדמת יותר



Shai Mizrachi
14/05/11, 00:52
יש לכם אייפון 3G ואתם נמצאים על גירסה 4.2.1 אבל רוצים להוריד אפליקציה הדורשת שתהיו על גירסה 4.3.3 (חדשה יותר) - למשל iGO primo LITE. או שאתם עם כל iDevice אחר, בגירסה נמוכה ומקבלים הודעת שגיאה שהאפליקציה דורשת גירסת מכשיר מתקדמת יותר - כאן הפיתרון.



דרישות מקדימות:
- מכשיר אייפון, אייפוד ואייפד 1 פרוץ
- תוכנת iFile מותקנת במכשיר


למי המדריך הזה מיודע?
המדריך מיועד למי שמנסה להתקין אפליקציה המותאמת לגירסאות iOS מתקדמות יותר מזאת המותקנת במכשיר, ומקבל את הודעת השגיאה הבאה בעת ניסיון ההתקנה:

"אפליקציה אינה תואמת
אפליקציה זאת דורשת גירסת קושחה XXX"


http://imageshack.us/m/818/3865/img2260.png


שלב ראשון - מציאת נתיב קובץ המערכת:

פתחו את תכנת iFile במכשירכם וחפשו את הנתיב הבא -
System/Library/CoreServices/SystemVersion.plist


http://imageshack.us/m/42/4190/img2262.png


שלב שני - איתור קובץ המערכת וצפיה בשדות הרלוונטים:

לחצו על הקובץ SystemVersion.plist המופיעה בתחתית רשימת הקבצים, ואז על Property List Viewer.


http://imageshack.us/m/843/575/img2261r.png


שלב שלישי - שינוי הגירסה:
ברשימה שקיבלתם בחרו ב ProductVersion ושנו לגירסה הרצויה.


http://imageshack.us/m/844/5835/img2264.png

http://imageshack.us/m/687/6299/img2265.png




שימו לב:

לאחר שהתקנתם את האפליקציה הדורשת גירסת קושחה חדשה יותר, מומלץ לחזור על שלבי המדריך המופיעים מעלה ולהחזיר את גירסת המכשיר שלכם לגירסה המקורית.

במידה ותהיתם האם זה עובד, או מה באמת הכח שבשינוי הקובץ הנ"ל, אז לידיעתכם שלפני כתיבת המדריך התקנתי את תכנת הניווט - iGo על מכשיר אייפון דור שני 2G וההתקנה הושלמה בהצלחה!
להזכירכם לאייפון דור שני אין GPS, וגירסת ה iOS המקסימלית שלו היא - 3.1.3 :)

בהצלחה :)


לדיון בנושא המדריך, לחצו על הלינק הבא:

דיון: מדריך | איך להוריד אפליקציות הדורשות גירסת iOS מתקדמות יותר (http://www.iphones.co.il/forum/thread186813.html)